Category Archives: Komputer

Fitur Fitur Firewall Server Untuk Bisnis Kecil (Small Business)

Kali ini saya akan berbagi sedikit pengetahuan umum untuk firewall server yang ditujukan kepada usaha kecil. Kita ketahui bahwa konektifitas jaringan internet sangat komplek sekali dan disitu banyak hal yang bisa kita lakukan. Dan perlu kita perhatikan adalah salah satunya dari segi keamanan (security) dijaringan kita.  Kalau tidak waspada akan hal ini sangat berdampak serius akan keamanan data perusahaan.  Tentunya untuk mengimplementasikan ini membutuhkan resources yang cukup untuk bisa melindungi keamanan data di perusahaan. Disini saya akan berbagi sedikit fitur yang diperlukan minimal untuk implementasi keamanan jaringan menggunakan firewall.

  • Internet Connection Support. Banyak firewall akan mendukung ADSL, VDSL, Ethernet dan dalam banyak kasus 4G. Pastikan firewall yang Anda pilih kompatibel dengan koneksi internet Anda.
  • Wirelles Support. Sebagian besar UKM menggunakan WIFI dalam beberapa bentuk. Saat ini Anda harus melihat 802.11AC untuk kinerja terbaik dan jika memungkinkan, Anda harus dapat mengamankan jaringan nirkabel menggunakan Kunci Pra-Shared, nama pengguna / kata sandi dan idealnya, firewall harus menampilkan WIDS (Intrusion Detection Service)
  • Anti Virus. Gateway antivirus berarti firewall memindai unduhan dan e-mail Anda untuk virus pada perangkat, menambahkan lapisan pertahanan tambahan ke antivirus yang ada di PC / Server Anda.
  • Intrusion Prevention Service (IPS). IPS memindai lalu lintas dan melihat pola yang mungkin menunjukkan potensi serangan atau eksploitasi terhadap jaringan atau desktop / server Anda. IPS dapat mengidentifikasi pola tersebut dan langsung memblokir serangan tersebut. Solusi IPS yang efektif jarang ditampilkan pada router SMB, namun umum terjadi pada firewall bisnis kecil seperti Fortigate.
  • Web Filtering tujuan utama penyaringan web adalah mengendalikan situs web yang dapat diakses atau tidak oleh staf Anda. Selain menyaring konten, fitur penting adalah memblokir akses ke situs web “berisiko tinggi” yang diketahui, situs web yang menginangi virus dan perangkat lunak jahat lainnya.
  • Reporting. Ini adalah kunci. Kemampuan firewall Anda untuk memberi tahu Anda atau penyedia firewall yang dikelola jika terjadi virus, malware, atau serangan terdeteksi. Ini harus mudah digunakan, sebaiknya dalam bentuk ringkasan eksekutif mingguan.
  • Virtual Private Networks (VPN). VPN memungkinkan akses jarak jauh ke tempat kerja dari rumah, seluler atau di jalan. Firewall SMB terkemuka akan mendukung IPSec dan SSL VPN yang memungkinkan Anda terhubung ke jaringan kantor dari manapun di internet. VPN Situs-ke-Situs memungkinkan Anda menghubungkan beberapa situs ke satu jaringan, menghubungkan kantor-kantor jauh, pabrik dan situs lainnya.
  • Technical Support. Ini penting. Dukungan teknis dapat diberikan oleh vendor atau oleh mitra firewall yang Anda kelola. Ini berarti Anda tidak perlu khawatir dengan konfigurasi, monitoring atau setup.

Itu adalah hal-hal yang perlu di pahami minimal dalam pemilihan firewall server untuk perusahaan.

Semoga bermanfaat.

Advertisements

Cara Configurasi Standard Access List (ACL)

Hi,

Bulan lalu saya sudah memposting tentang access control list (ACL) yang terdiri dari standard access list dan extended access list. Hari ini saya akan coba memberikan contoh penggunanaan standard access list menggunakan packet tracer. Ini yang perlu diingat dalam menerapkan konfigurasi standard access list “Standard IP access-lists are based upon the source host or network IP
address, and should be placed closest to the destination network”.

Di bawah ini akan saya lampirkan gambar konfigurasi standard acl :

 

 

 

 

Dari gambar diatas saya memberikan 2 contoh kasus konfigurasi standard access list yaitu :

  1. Block network192.168. 30.0  /24 dan network 192.168. 40.0  /24 untuk ping ke 192.168.50.0 /24 kecuali network 192.168. 60.0 /24 :
  • access-list 10 permit 192.168.60.0 0.0.0.255
  • access-list 10 deny 192.168.50.0 0.0.0.255
  • access-list 10 permit any
  • apply to router 0
  • se 0/0
  • ip access-list group in

2. Block network 192.168.50.0 /24 ke network 192.168.30.0 /24, sedangkan ping ke lain network berjalan lancar.

  • access-list 20 deny 192.168.30.0 0.0.0.255
  • access-list 20 permit any
  • apply to router 1
  • int f0/0
  • ip access-group 20 out

Detail configurasi ada di bawah ini :

Router1
========

Router>en
Router#
Router#
Router#
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int se0/0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up

Router>en
Router#
Router#
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int se0/0
Router(config-if)#ip address 192.168.20.2 255.255.255.252
Router(config-if)#no shut
Router(config-if)#
Router(config-if)#exit
Router(config)#
Router(config)#
Router(config)#exit
Router#

Router#
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/1
Router(config-if)#ip address 192.168.60.1 255.255.255.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router(config-if)#
Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip address 192.168.50.1 255.255.255.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#
Router(config-if)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 192.168.20.0
Router(config-router)#network 192.168.50.0
Router(config-router)#network 192.168.60.0
Router(config-router)#exit
Router(config)#
Router(config)#
Router(config)#exit
Router#

 

Router0
========
Router>en
Router#
Router#
Router#
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int se0/0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up

Router#
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int se0/0
Router(config-if)#ip address 192.168.20.1 255.255.255.252
Router(config-if)#no shut
Router(config-if)#
Router(config-if)#exit
Router(config)#
Router(config)#
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)#int fa0/1
Router(config-if)#ip address 192.168.30.1 255.255.255.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip address 192.168.40.1 255.255.255.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#
Router(config-if)#exit
Router(config)#
Router(config)#
Router(config)#exit

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 192.168.20.0
Router(config-router)#network 192.168.40.0
Router(config-router)#network 192.168.30.0
Router(config-router)#
Router(config-router)#exit
Router(config)#
Router(config)#
Router(config)#exit
Router#

Router#
Router#
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)#access-list 10 permit 192.168.60.0 0.0.0.255
Router(config)#access-list 10 deny 192.168.50.0 0.0.0.255
Router(config)#access-list 10 permit any
Router(config)#
Router(config)#
Router(config)#int se0/0
Router(config-if)#ip access-group 10 in
Router(config-if)#
Router(config-if)#exit
Router(config)#
Router(config)#
Router(config)#
Router(config)#
Router(config)#exit
Router#

Untuk script diatas saya memberikan contoh untuk kasus yang pertama, sedangkan untuk yang kasus yang kedua silahkan anda coba sendiri.

Bagi teman teman yang ingin lebih details tentang gambar yang saya lampirkan karena kurang jelas bisa konfirmasi ke saya, nanti akan saya kirimkan.

Semoga bermanfaat.

Terimakasih.

Access Control List

Hi,

Hari ini saya coba berbagi tentang access control list atau biasa disebut ACL.  Fasilitas ini biasa kita gunakan untuk sebagai filter atau firewall didalam cisco router.

Apa itu Access Control List :

  • statement yang berisikan daftar “permit” atau “deny” yang berurutan di dalam list
  • statement akan dibaca secara berurutan sampai dengan kondisi yang cocok atau sama
  • statement akan berhenti jika sudah sesuai dengan kondisi
  • jika statement tidak cocok dengan kondisi makan akan langsung “dropped”
  • statement harus di terapkan (apply) agar berjalan untuk menghasilkan effect yang diminta

Ada dua jenis ACL

  • Standard access control list (1-99) or (1300 – 1999)
    – acts only on the source Ip address for filtering
  • Extended acl (100 – 199) or (2000 – 2699 )
    – filter on:
    – source ip address
    – destination ip address
    – protocol type
    – port number

Aturan dalam penulisan / penerapan ACL

  • satu list per type, per interface, per direction ( in – out )
  • list nomor untuk type ACL
  • – standar : 1-99 0r 1300-1999
    – extended : 100-199 or 2000-2699

standard access list syntax
– access-list [1-99] [permit|deny] [wildcard bits]
extended access list syntax
– access-list [100-199] [permit | deny] [protocol] [wildcard mask] [destination address] [wildcard mask] [operator [port]] [log]

Untuk saat ini itu yang bisa saya sampaikan, untuk contoh standard dan extended list nanti akan saya berikan di post berikutnya.

 

Apa beda HTTP dan HTTPS???

Ok, hari ini saya akan mencoba memberikan sedikit gambaran perbedaan antara HTTP dan HTTPS. Kenapa ini saya tuliskan di blog ini karena jujur saja banyak yang bertanya tentang perbedaaan http dan https yang dikarenakan hanya beda satu huruf saja di belakang huruf “S” tapi banyak perbedaan dan cara kerjanya.  Saya sendiri terkadang lupa untuk menjawabnya hehehehe…..

HTTP :

HyperText Transfer Protokol, dimana untuk http sering kita gunakan pada saat kita melakukan browsing di internet, protokol ini lah yang membantu anda melihat halaman internet yang anda minta di browser tersebut. HTTP ini menggunakan port 80 untuk berkomunikasi dengan server yang kita tuju supaya dari pihak server merespon kembali ke klien

HTTPS :

HyperText Transfer Protokol Secure, hal yang sama dengan http untuk cara kerjanya akan tetapi ditambah dengan fitur lapisan keamanan dalam bentuk TLS/SSL, protocol ini menggunakan port 443. Sehingga server dan klien berkomunikasi dengan lebih aman menggunakan protocol ini. Dalam penggunaan https ini diharuskan untuk mempunyai sertifikat SSL yang mana dapat memungkinkan untuk melakukan enkripsi data antara server dan klien.

Ini sedikit gambaran perbedaan http dan https yang bisa saja berikan, semoga membantu. :))

 

 

Cara Install Packet Tracer 7.0 di Ubuntu

Hi semua,

Kali ini saya akan memberikan sedikit tutorial bagaimana cara untuk melakukan instalasi software packet tracer di Ubuntu. Disini saya menggunakan packet tracer versi 7.0, kita ketahui bahwa packet tracer adalah simulator aplikasi dari cisco untuk melakukan pengujian / pengetesan jaringan menggunakan perangkat cisco secara virtual. Ok langsung saja ke langkah – langkahnya:

  • Download terlebih dahulu packet tracernya, https://drive.google.com/file/d/0B7zGwz0yWP8QZTVyTjRieGFFRHM/view (untuk versi 32 bit) , https://drive.google.com/file/d/0B7zGwz0yWP8QZWo2dGhjR2E3ck0/view (untuk versi 64 bit)
  • Setelah terdownload file tersebut bisa disimpan dimana anda suka, untuk saya pribadi saya simpan di folder Downloads.
  • Buka terminal di Ubuntu dengan cara klik Ctrl + Alt + T
  • Ketikkan $ cd Downloads
  • tar -xvzf PacketTracer70_32bit_linux.tar.gz (untuk mengextrac file yang sudah didownload)
  • cd PacketTracer70 (masuk ke file hasil extract file tadi)
  • ./install (ikutin step yang berjalan sampai selesai)

Untuk membuka aplikasi yang terinstall ketikkan $ sudo packettracer

Semoga membantu

Salam

Hwijaya

Setup DHCP Server di Packet Tracer

Hi semua apa kabar, cukup lama saya tidak posting di blog ini dan sekarang saya coba mau sedikit berbagi tentang dhcp server yang biasa kita temui di lingkungan kerja kita terutama untuk network yang kita gunakan. Tentu kita tahu bahwa penggunaan jaringan di tempat kerja kita ataupun dimana saja pasti berhubungan dengan ip disetiap pc yang terhubung dan tentu saja kita harus menyediakannya. Akan sedikit repot jika kita menggunakan cara manual untuk input ip di setiap pc/ laptop yang terhubug. Dengan  bantuan DHCP server akan sangat meringankan pekerjaan kita dalam hal meload ip ke setiap user.

Ok langsung saja saya akan berikan detail tentang dhcp server seperti topology jaringan diatas.

  • Router sebagai DHCP server
  • 1 PC untuk DNS server
  • 1 Switch

Router akan berfungsi memberikan ip otomatis kepada user yang terhubung ke switch. Disini switch terdiri dari 3 Vlan antara lain : vlan 1 (192.168.10.0/24), vlan 20 marketing (192.168.20.0/24) dan vlan 30 technical (192.168.30.0/24) sedangkan DNS-server pc kita kasih IP 192.168.10.2.

Router :

Router>
Router>en
Router#
Router#
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int f0/0
Router(config-if)#ip address 192.168.10.1 255.255.255.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#ip dhcp pool lan1
Router(dhcp-config)#default-router 192.168.10.1
Router(dhcp-config)#network 192.168.10.0 255.255.255.0
Router(dhcp-config)#dns-server 192.168.10.2
Router(dhcp-config)#
Router(dhcp-config)#ip dhcp excluded-address 192.168.10.1 192.168.10.10
Router(config)#
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#
Router#
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#ip dhcp pool marketing
Router(dhcp-config)#default-router 192.168.10.1
Router(dhcp-config)#network 192.168.20.0 255.255.255.0
Router(dhcp-config)#dns-server 192.168.10.2
Router(dhcp-config)#exit
Router(config)#int f0/0.20
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up

Router(config-subif)#
Router(config-subif)#encap dot1q 20
Router(config-subif)#network 192.168.20.0 255.255.255.0
Router(config-subif)#ip address 192.168.20.5 255.255.255.0
Router(config-subif)#exit
Router(config)#
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int f0/0.30
Router(config-subif)#encap dot1q 30
Router(config-subif)#network 192.168.30.0 255.255.255.0
Router(config-subif)#ip address 192.168.30.1 255.255.255.0
Router(config-subif)#
Router(config-subif)#
Router(config-subif)#exit
Router(config)#
Router(config)#exit
Router#

switch
=======
Switch#
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 30
Switch(config-vlan)#name technical
Switch(config-vlan)#
Switch(config-vlan)#
Switch(config-vlan)#exit
Switch(config)#
Switch(config)#
Switch(config)#int f0/11
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30
Switch(config-if)#int f0/12
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30
Switch(config-if)#
Switch(config-if)#exit
Switch(config)#
Switch(config)#exit
Switch#

Semoga bermanfaat 🙂

Apa itu Shadow IT?

Informasi ini saya dapat dari link ini http://www.detiknas.go.id/2016/11/25/tahukah-kamu-apa-itu-shadow-it/.

Semoga bisa memberikan tambahan wawasan. 🙂

Sekarang adalah masa dimana segala hal berbasis multi-media, multi-perangkat dan multi- Operation System (OS). Kita sudah menemukan ada banyak jenis perangkat smartphone dan tablet menggunakan berbagai OS, seperti Windows, iOS serta Android. Semua jenis perangkat dan sistem tersebut banyak digunakan untuk bekerja atau berbisnis, namun ada hal yang seringkali dieluhkan yaitu mengenai sistem penyimpanan data.

Para pekerja maupun pebisnis kebanyakan menginginkan kemudahan dan kenyamanan dalam penyimpanan data serta mendapatkan tempat penyimpanan pribadi yang lebih murah. Maka dari itu, sebagian besar dari mereka memanfaatkan Shadow IT yang bisa dengan mudah diakses melalui semua jenis operasi sistem handphone.

Shadow IT adalah istilah yang digunakan untuk menggambarkan sistem teknologi informasi yang dibangun untuk memberikan solusi tanpa adanya persetujuan dari organisasi itu sendiri. Dalam kata lain, Shadow IT adalah hal yang “tidak resmi”.

Meskipun Shadow IT bukanlah sistem resmi, namun telah memberikan kemudahan dan inovasi bagi para pekerja kantor maupun pebisnis, karena Shadow IT bisa dengan mudah digunakan dan disebarkan melalui perangkat pribadi, seperti DropBox, media sosial, Chat Messenger, Google Docs, Gmail dan lain sebagainya.

Cara ini memang dianggap fleksibel dalam penyimpanan data karena menggunakan pengaturan privasi. Shadow IT sangat cocok bagi mereka yang bekerja secara mobile agar lebih efektif dan efisien.

Tidak dipungkiri bahwa sebenarnya Shadow IT bisa menjadi sumber penting dalam peningkatan inovasi dan kinerja karyawan ataupun pebisnis, karena jenis cloud sistem ini bisa menjadi prototipe untuk solusi TIK masa depan. Namun, di sisi lain Shadow IT masih menjadi hal yang tidak sesuai dengan kinerja sebuah organisasi dilihat dari keamanan, kontrol dan kehandalan. (ar/fs/sb)