Category Archives: Programming

Semua tentang pemrograman

Setup DHCP Server di Packet Tracer

Hi semua apa kabar, cukup lama saya tidak posting di blog ini dan sekarang saya coba mau sedikit berbagi tentang dhcp server yang biasa kita temui di lingkungan kerja kita terutama untuk network yang kita gunakan. Tentu kita tahu bahwa penggunaan jaringan di tempat kerja kita ataupun dimana saja pasti berhubungan dengan ip disetiap pc yang terhubung dan tentu saja kita harus menyediakannya. Akan sedikit repot jika kita menggunakan cara manual untuk input ip di setiap pc/ laptop yang terhubug. Dengan  bantuan DHCP server akan sangat meringankan pekerjaan kita dalam hal meload ip ke setiap user.

Ok langsung saja saya akan berikan detail tentang dhcp server seperti topology jaringan diatas.

  • Router sebagai DHCP server
  • 1 PC untuk DNS server
  • 1 Switch

Router akan berfungsi memberikan ip otomatis kepada user yang terhubung ke switch. Disini switch terdiri dari 3 Vlan antara lain : vlan 1 (192.168.10.0/24), vlan 20 marketing (192.168.20.0/24) dan vlan 30 technical (192.168.30.0/24) sedangkan DNS-server pc kita kasih IP 192.168.10.2.

Router :

Router>
Router>en
Router#
Router#
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int f0/0
Router(config-if)#ip address 192.168.10.1 255.255.255.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#ip dhcp pool lan1
Router(dhcp-config)#default-router 192.168.10.1
Router(dhcp-config)#network 192.168.10.0 255.255.255.0
Router(dhcp-config)#dns-server 192.168.10.2
Router(dhcp-config)#
Router(dhcp-config)#ip dhcp excluded-address 192.168.10.1 192.168.10.10
Router(config)#
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#
Router#
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#ip dhcp pool marketing
Router(dhcp-config)#default-router 192.168.10.1
Router(dhcp-config)#network 192.168.20.0 255.255.255.0
Router(dhcp-config)#dns-server 192.168.10.2
Router(dhcp-config)#exit
Router(config)#int f0/0.20
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up

Router(config-subif)#
Router(config-subif)#encap dot1q 20
Router(config-subif)#network 192.168.20.0 255.255.255.0
Router(config-subif)#ip address 192.168.20.5 255.255.255.0
Router(config-subif)#exit
Router(config)#
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int f0/0.30
Router(config-subif)#encap dot1q 30
Router(config-subif)#network 192.168.30.0 255.255.255.0
Router(config-subif)#ip address 192.168.30.1 255.255.255.0
Router(config-subif)#
Router(config-subif)#
Router(config-subif)#exit
Router(config)#
Router(config)#exit
Router#

switch
=======
Switch#
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 30
Switch(config-vlan)#name technical
Switch(config-vlan)#
Switch(config-vlan)#
Switch(config-vlan)#exit
Switch(config)#
Switch(config)#
Switch(config)#int f0/11
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30
Switch(config-if)#int f0/12
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30
Switch(config-if)#
Switch(config-if)#exit
Switch(config)#
Switch(config)#exit
Switch#

Semoga bermanfaat 🙂

Advertisements

Copy Tabel Data Menggunakan MySql Command

Banyak sekali dalam membuat tabel dalam database kita harus melakukannya satu persatu setial tabel yang akan kita buat dan ini terkadang membutuhkan waktu yang cukup lama jika kita akan membuat database dengan tabel yang banyak. Nah untuk mempersingkat ini saya coba beri cara agar mempermudah dan mempercepat dalam pembuatan tabel. Perlu di ingat bahwa tabel yang akan kita buat ini atau kita copy dari tabel yang sudah ada tinggal kita ganti nama tabelnya saja.

Berikut contoh syntax mysqlnya :

– Jika tabel belum ada sebelumnya :

” CREATE TABLE dest_table(nama table baru) (SELECT * FROM source_table); ”

– Jika tabel sudah ada :

” INSERT INTO dest_table (SELECT * FROM source_table);”

Catatan: tidak menggunakan tanda petik.

Semoga Bermanfaat.

Salam

HebatWijaya

 

Cara Menampilkan Data Tabel MySql dengan PHP dan HTML

Kalo ini saya akan  memberikan tutorial sedikit tentang program khususnya dengan bahasa PHP. Akan banyak yg akan saya berikan tetapi untuk pertama ini saya akan coba berbagi script bagaimana kita menampilkan data tabel yg ada di mysql ke dalam brower menggunakan PHP dan HTML. Asumsi saya bagi yang membaca tulisan ini bahwa paling tidak sudah mengerti bagaimana menjalankan PHP.  Langsung saja ini script codenya :

<?php
//buat koneksi dengan MySQL
$hostname = “localhost”;
$user = “root”;
$password = “”;
$database = “samudera”;
$koneksi = mysql_connect ($hostname, $user, $password);
$pilihdb = mysql_select_db ($database, $koneksi);

//jika koneksi gagal, langsung keluar dari PHP
if (!$koneksi)
{
die(“Koneksi dengan MySQL gagal”);
}

//Menggunakan database universitas yang sudah dibuat
$result=mysql_query(‘USE samudera’);
if (!$result)
{
die(“Database samudera tidak terkoneksi”);
}

//menampilkan table inventory dari database mysql
$result=mysql_query(‘SELECT * FROM tbl_inventory’);
?>
<!DOCTYPE html>
<head>

</head>

<body>
<h3>Menampilkan data tabel MySQL dengan PHP dan HTML</h3>
<table>
<tr>
<th>Nama User</th>
<th>Service Tag</th>
<th>Department</th>
<th>Location</th>
<th>Monitor</th>
<th>Monitor</th>
<th>Type</th>
<th>Serial Number</th>
<th>Operating System</th>
<th>Memory</th>
<th>Procesor</th>
<th>Description</th>
<th>Cisco</th>
</tr>
<?php
while ($row=mysql_fetch_array($result))
{
echo “<tr>”;
echo “<td>”.$row[‘user’].”</td>”;
echo “<td>”.$row[‘service_tag’].”</td>”;
echo “<td>”.$row[‘department’].”</td>”;
echo “<td>”.$row[‘location’].”</td>”;
echo “<td>”.$row[‘monitor’].”</td>”;
echo “<td>”.$row[‘type’].”</td>”;
echo “<td>”.$row[‘serialnumber’].”</td>”;
echo “<td>”.$row[‘os’].”</td>”;
echo “<td>”.$row[‘memory’].”</td>”;
echo “<td>”.$row[‘procesor’].”</td>”;
echo “<td>”.$row[‘description’].”</td>”;
echo “<td>”.$row[‘cisco’].”</td>”;
echo “</tr>”;
}
?>
</table>
</body>
</html>

Untuk field database bisa ditentukan sendiri terserah imajinasi dan kebutuhan. Selamat mencoba dan semoga berguna.

Tunggu script code selanjutnya.