Konsep Paket Filtering – Firewall

Hi semua apa kabar? semoga baik ya…amin. Sudah hampir 2 bulan saya tidak posting artikel di blog ini, maklum sekarang lagi jobbles jadi keliling jadi tukang freelance hehehehe.

Hari ini saya akan sedikit berbagi artikel tentang firewall (konsep filter) di mikrotik.  Firewall berfungsi untuk meningkatkan keamanan jaringan kita dari paket data apa saja yang masuk atau keluar dari jaringan yang kita miliki. Inilah fungsi dari firewall dimana bisa untuk menentukan paket data apa saja yang kita terima(accept) ataupun ditolak(drop).  Di dalam mikrotik firewall bekerja menggunakan parameter chain dimana ini akan digunakan untuk membuat rule yang akan diimplementasikan didalam jaringan kita.

Ada 3  bentuk default chain di dalam router mikrotik yaitu input, forward dan output. Akan saya jelaskan masing2 fungsi chain tersebut :

  • Chain Input : Paket data yang berasal dari komputer client dan ditujukan ke setiap interface yang ada di mikrotik. Misalnya pada saat kita melakukan konfigurasi menggunakan winbox, telnet, ssh.
  • Chain Foward : Paket data yang berasal dari komputer client dan menuju ke internet. Paket ini tidak ditujukan ke interface mikrotik melainkan langsung ke internet dan seolah olah komputer client melewati router mikrotik.
  • Chain Ouput : Paket ini berasal dari router itu sendiri dan ditujukan ke host yang ada di internet. Contoh paket ini adalah web proxy yang diaktifkan oleh router mikrotik.

Untuk sementara ini saja yang saya post tentang konsep firewall filtering mikrotik. Untuk lebih detail tentang implementasi konfigurasi di mikrotik tunggu di post2 berikutnya.

Semoga bermanfaat.

Salam

HebatWijaya

Advertisements

Apa itu RADIUS

Kalian tentu sudah sering mendengar tentang RADIUS terutama bagi teman teman yang menyukai dengan jaringan / network. RADIUS adalah Remote Authentication Dial-In User Service dimana protokol dan perangkat lunak klien / server yang memungkinkan server akses remote untuk berkomunikasi dengan server pusat untuk mengotentikasi pengguna dial-in dan mengotorisasi akses mereka ke sistem atau layanan yang diminta. RADIUS memungkinkan perusahaan untuk mempertahankan profil pengguna dalam basis data pusat yang dapat dibagikan oleh semua server jarak jauh. Ini memberikan keamanan yang lebih baik, memungkinkan perusahaan untuk membuat kebijakan yang dapat diterapkan pada satu titik jaringan yang dikelola. Memiliki layanan pusat juga berarti bahwa lebih mudah untuk melacak penggunaan untuk penagihan dan untuk menjaga statistik jaringan. Dibuat oleh Livingston (sekarang dimiliki oleh Lucent), RADIUS adalah standar industri de facto yang digunakan oleh sejumlah perusahaan produk jaringan dan merupakan standar IETF yang diusulkan.

Penerapan radius ini tentunya banyak yang sudah kita ketahui dengan menggunakan beberapa tool network diantaranya adalah RadClient, NTRadPing, RadPerf dan lain-lain. Di lain waktu nanti akan saya share untuk configurasi Radius dengan menggunakan tools yang ada.

Semoga membantu.

Cara Menampilkan Tabel Data Dengan Background Warna

Hi semua,

Kali ini saya akan memberikan tips bagaimana membuat tabel dengan background warna di website menggunakan php mysql. Untuk tampilannya bisa ada lihat dibawah ini :

Langsung saja ini script php :

<html>
<head>
<title>Tes Koneksi MySQL</title>
</head>
<body>

<?php
$server = “localhost”;
$pemakai = “root”;
$password = “”;

$id_mysql = mysql_connect($server, $pemakai, $password);
if (! $id_mysql)
die(“Tak dapat melakukan koneksi ke server MySQL”);

print(“Koneksi ke MySQL bisa dilakukan\n<br>”);

$db_penduduk = mysql_select_db(“penduduk”, $id_mysql);
if (! $db_penduduk)
die(“Tak dapat mengakses database penduduk”);

print(“Database penduduk bisa diakses\n<br>”);

// bagian untuk membaca data
$sql = “select * from tabel_data_penduduk”;
$hasil = mysql_query($sql, $id_mysql);
if (! $hasil)
die(“salah SQL”);

//menambahkan kolom nomor dan akan secara otomatis bertambah atau berurutan sesuai data yang kita masukkan.

$nomor = 0;

print(“<table width = \”80%\” border=\”1\”>\n”);
print(“<tr>\n”);
print(“<td width=\”10%\”>Nomor</td>\n”);
print(“<td width=\”10%\”>Nomor KTP</td>\n”);
print(“<td width=\”15%\”>Nomor SIM</td>\n”);
print(“<td width=\”15%\”>Nama</td>\n”);
print(“<td width=\”20%\”>Tanggal Lahir</td>\n”);
print(“<td width=\”30%\”>Kode Kota</td>\n”);

while ($baris = mysql_fetch_row($hasil))
{

$nomor++;

//memberikan background warna  pada tabel, warna bisa anda sesuaikan dengan keinginan.

//$nomor%2 ==0 adalah menghasilkan nilai benar jika isi variabel $nomor berupa bilangan genap.

if ($nomor % 2 == 0)
$warna_belakang = “#99ffff”;
else
$warna_belakang = “#99ccff”;

$No_KTP = $baris[0];
$No_SIN = $baris[1];
$Nama = $baris[2];
$Tgl_Lahir = $baris[3];
$Kode_Kota = $baris[4];

print(“<tr bgcolor= \”$warna_belakang\”>\n”);
print(“<td>$nomor</td>\n”);
print(“<td>$No_KTP</td>\n”);
print(“<td>$No_SIN</td>\n”);
print(“<td>$Nama</td>\n”);
print(“<td>$Tgl_Lahir</td>\n”);
print(“<td>$Kode_Kota</td>\n”);

//membuat kolom edit pada tabel disetiap baris

print(“<td><a href=\”editdata.php?kode=$No_KTP\”>” .
“Edit</a></td>\n”);

}

print(“</table>\n”);

// akhir pembacaan data
mysql_close($id_mysql);
?>

</body>
</html>

Semoga bermanfaat.

Konfigurasi Dasar Mikrotik

Halo semua,

Kali ini saya akan membuat postingan baru tentang mikrotik, kita tahu semua bahwa mikrotik sangat dikenal  banyak oleh kalangan IT di Indonesia karena baik fungsi dan harganya relatif terjangkau, dan juga bisa digunakan untuk personal maupun kalangan bisnis. Saya akan memposting tentang mikrotik sebagai sebuah router yang banyak sekali kelengkapannya yang berhubungan dengan jaringan baik skala kecil maupun besar. Pada kesempatan kali ini saya akan membuat konfigirasi dasar untuk mikrotik supaya terkoneksi dengan internet. Setelah postingan ini, saya akan coba terus memberikan konfigurasi yang lebih lengkap lagi tentang banyak hal di mikrotik.

Langsung saja, melihat gambar diatas saya membuat rencana topologi jaringan dengan mikrotik, pada router mikrotik terlihat bahwa ethernet1 terhubung dengan ISP, oleh karena itu kita konfigurasikan ethernet1 dengan ip 70.1.1.2/30, sedangkan untuk ethernet2 yang mana terhubung dengan jaringan lokal kita konfigurasikan dengan ip 10.10.10.1/24. Untuk DNS sendiri kita berikan ip 70.1.1.1

Konfigurasi ip address :

[admin@mikrotik] ip address add address=60.1.1.2/30 interface=ether1

[admin@mikrotik] ip address add address=10.1.1.1/24 interface=ether2

gunakan ip address print untuk melihat hasilnya, sedangkan menggunakan winbox bisa diakses melalui menu IP–>Addresses–>tombol ADD.

Langkah selanjutnya adalah konfigurasikan ip gateway, default gateway ini berfungsi untuk gerbang mikrotik anda supaya terhubung dengan internet. Dimana di skenario ini gateway ISPnya adalah 70.1.1.1.

[admin@mikrotik] ip route add dst-address=0.0.0.0/0 gateway=70.1.1.1

gunakan ip route print untuk melihat hasilnya, untuk winbox bisa dilakukan dengan menu IP–>Routes,tab Routes–>Add.

Sekarang adalah konfigurasi DNS server, kita ketahui bahwa di skenario kita dns server adalah 70.1.1.1, maka perintahnya sebagai berikut:

[admin@mikrotik] ip dns set servers=70.1.1.1 allow-remote-requests=yes

gunakan ip dns print untuk melihat hasilnya, untuk winbox bisa dilihat menu IP–>DNS–>tombol Settings. Setelah ini semua dikonfigrasikan makan bisa dilakukan test ping ke internet. Sampai disini konfigurasikan kita sudah terkoneksi ke internet, tetapi untuk pc client belum bisa akses ke internet, kita harus lakukan satu konfigurasi lagi menggunakan fasilitas Masquerade yang dimana funginya adalah untuk merubah private ip address dijaringan lokal kita ke public ip address pada ether1 supaya bisa berkomunikasi dengan internet, langkahnya adalah :

[admin@mikrotik] ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade.

untuk diwinbox pilih menu IP–>Firewall–>tab NAT pilih masquerade pada tab Action.

Berikan pada masing2 pc ip statik sesuai dengan gambar diatas, coba koneksikan ke internet.

Tunggu posting selanjutnya.

Semoga membantu .

 

 

Cara membuat FTP server sebagai drive di Window Explorer

Hi,

Kali ini saya akan berbagi tentang cara membuat ftp server sebagai drive di windows exlorer.  Penggunaan ftp server ini biasanya digunakan untuk melakukan transfer data yang besar dan akan sangat mudah jika kita bisa intergrasikan dengan windows explorer.

Ok langsung ini langkah-langkahnya ;

– Klik kanan pada pilihan “Computer” atau “This PC” lalu pilih perintah “Add a network location”.

– Setelah menekan tombol “Next” sebanyak 2 kali, cari alamat FTP server yang akan dikoneksikan, kemudian kalian dapat memasukkan username atau tanpa identitas untuk log in lalu klik “Finish”. Kemudian windows explorer akan terbuka. Kalian akan lebih mudah dalam melakukan transfer data.

Cukup mudah memang, dan semoga bisa bermanfaat.

Salam

HebatWijaya

 

Fitur Fitur Firewall Server Untuk Bisnis Kecil (Small Business)

Kali ini saya akan berbagi sedikit pengetahuan umum untuk firewall server yang ditujukan kepada usaha kecil. Kita ketahui bahwa konektifitas jaringan internet sangat komplek sekali dan disitu banyak hal yang bisa kita lakukan. Dan perlu kita perhatikan adalah salah satunya dari segi keamanan (security) dijaringan kita.  Kalau tidak waspada akan hal ini sangat berdampak serius akan keamanan data perusahaan.  Tentunya untuk mengimplementasikan ini membutuhkan resources yang cukup untuk bisa melindungi keamanan data di perusahaan. Disini saya akan berbagi sedikit fitur yang diperlukan minimal untuk implementasi keamanan jaringan menggunakan firewall.

  • Internet Connection Support. Banyak firewall akan mendukung ADSL, VDSL, Ethernet dan dalam banyak kasus 4G. Pastikan firewall yang Anda pilih kompatibel dengan koneksi internet Anda.
  • Wirelles Support. Sebagian besar UKM menggunakan WIFI dalam beberapa bentuk. Saat ini Anda harus melihat 802.11AC untuk kinerja terbaik dan jika memungkinkan, Anda harus dapat mengamankan jaringan nirkabel menggunakan Kunci Pra-Shared, nama pengguna / kata sandi dan idealnya, firewall harus menampilkan WIDS (Intrusion Detection Service)
  • Anti Virus. Gateway antivirus berarti firewall memindai unduhan dan e-mail Anda untuk virus pada perangkat, menambahkan lapisan pertahanan tambahan ke antivirus yang ada di PC / Server Anda.
  • Intrusion Prevention Service (IPS). IPS memindai lalu lintas dan melihat pola yang mungkin menunjukkan potensi serangan atau eksploitasi terhadap jaringan atau desktop / server Anda. IPS dapat mengidentifikasi pola tersebut dan langsung memblokir serangan tersebut. Solusi IPS yang efektif jarang ditampilkan pada router SMB, namun umum terjadi pada firewall bisnis kecil seperti Fortigate.
  • Web Filtering tujuan utama penyaringan web adalah mengendalikan situs web yang dapat diakses atau tidak oleh staf Anda. Selain menyaring konten, fitur penting adalah memblokir akses ke situs web “berisiko tinggi” yang diketahui, situs web yang menginangi virus dan perangkat lunak jahat lainnya.
  • Reporting. Ini adalah kunci. Kemampuan firewall Anda untuk memberi tahu Anda atau penyedia firewall yang dikelola jika terjadi virus, malware, atau serangan terdeteksi. Ini harus mudah digunakan, sebaiknya dalam bentuk ringkasan eksekutif mingguan.
  • Virtual Private Networks (VPN). VPN memungkinkan akses jarak jauh ke tempat kerja dari rumah, seluler atau di jalan. Firewall SMB terkemuka akan mendukung IPSec dan SSL VPN yang memungkinkan Anda terhubung ke jaringan kantor dari manapun di internet. VPN Situs-ke-Situs memungkinkan Anda menghubungkan beberapa situs ke satu jaringan, menghubungkan kantor-kantor jauh, pabrik dan situs lainnya.
  • Technical Support. Ini penting. Dukungan teknis dapat diberikan oleh vendor atau oleh mitra firewall yang Anda kelola. Ini berarti Anda tidak perlu khawatir dengan konfigurasi, monitoring atau setup.

Itu adalah hal-hal yang perlu di pahami minimal dalam pemilihan firewall server untuk perusahaan.

Semoga bermanfaat.

Cara Configurasi Standard Access List (ACL)

Hi,

Bulan lalu saya sudah memposting tentang access control list (ACL) yang terdiri dari standard access list dan extended access list. Hari ini saya akan coba memberikan contoh penggunanaan standard access list menggunakan packet tracer. Ini yang perlu diingat dalam menerapkan konfigurasi standard access list “Standard IP access-lists are based upon the source host or network IP
address, and should be placed closest to the destination network”.

Di bawah ini akan saya lampirkan gambar konfigurasi standard acl :

 

 

 

 

Dari gambar diatas saya memberikan 2 contoh kasus konfigurasi standard access list yaitu :

  1. Block network192.168. 30.0  /24 dan network 192.168. 40.0  /24 untuk ping ke 192.168.50.0 /24 kecuali network 192.168. 60.0 /24 :
  • access-list 10 permit 192.168.60.0 0.0.0.255
  • access-list 10 deny 192.168.50.0 0.0.0.255
  • access-list 10 permit any
  • apply to router 0
  • se 0/0
  • ip access-list group in

2. Block network 192.168.50.0 /24 ke network 192.168.30.0 /24, sedangkan ping ke lain network berjalan lancar.

  • access-list 20 deny 192.168.30.0 0.0.0.255
  • access-list 20 permit any
  • apply to router 1
  • int f0/0
  • ip access-group 20 out

Detail configurasi ada di bawah ini :

Router1
========

Router>en
Router#
Router#
Router#
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int se0/0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up

Router>en
Router#
Router#
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int se0/0
Router(config-if)#ip address 192.168.20.2 255.255.255.252
Router(config-if)#no shut
Router(config-if)#
Router(config-if)#exit
Router(config)#
Router(config)#
Router(config)#exit
Router#

Router#
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/1
Router(config-if)#ip address 192.168.60.1 255.255.255.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router(config-if)#
Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip address 192.168.50.1 255.255.255.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#
Router(config-if)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 192.168.20.0
Router(config-router)#network 192.168.50.0
Router(config-router)#network 192.168.60.0
Router(config-router)#exit
Router(config)#
Router(config)#
Router(config)#exit
Router#

 

Router0
========
Router>en
Router#
Router#
Router#
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int se0/0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up

Router#
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int se0/0
Router(config-if)#ip address 192.168.20.1 255.255.255.252
Router(config-if)#no shut
Router(config-if)#
Router(config-if)#exit
Router(config)#
Router(config)#
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)#int fa0/1
Router(config-if)#ip address 192.168.30.1 255.255.255.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip address 192.168.40.1 255.255.255.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#
Router(config-if)#exit
Router(config)#
Router(config)#
Router(config)#exit

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 192.168.20.0
Router(config-router)#network 192.168.40.0
Router(config-router)#network 192.168.30.0
Router(config-router)#
Router(config-router)#exit
Router(config)#
Router(config)#
Router(config)#exit
Router#

Router#
Router#
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)#access-list 10 permit 192.168.60.0 0.0.0.255
Router(config)#access-list 10 deny 192.168.50.0 0.0.0.255
Router(config)#access-list 10 permit any
Router(config)#
Router(config)#
Router(config)#int se0/0
Router(config-if)#ip access-group 10 in
Router(config-if)#
Router(config-if)#exit
Router(config)#
Router(config)#
Router(config)#
Router(config)#
Router(config)#exit
Router#

Untuk script diatas saya memberikan contoh untuk kasus yang pertama, sedangkan untuk yang kasus yang kedua silahkan anda coba sendiri.

Bagi teman teman yang ingin lebih details tentang gambar yang saya lampirkan karena kurang jelas bisa konfirmasi ke saya, nanti akan saya kirimkan.

Semoga bermanfaat.

Terimakasih.